Chrome 45 </3 Dymo Printing

This article is old and outdated. For the latest Dymo information check here.

As of September 3rd, 2015, the latest version of Google Chrome (45) no longer supports NPAPI plugins, which are needed to print labels. Dymo hopes to have a more permanent solution in place soon, but for now, you'll want to use Firefox. Here's how to do this quickly.

Download Firefox

If you don't already have Firefox, Download It Here

Create a New Station

For the time being, we've added one more option when creating a Station. You can see at the top there is a "Moving from Google Chrome?" option. Select the Station name you'd like to copy. This will delete the chrome station and replace it with an identical Firefox station.

Allow Plugins in Firefox

You may need to give permission for Firefox to print to this Station. At the top left 

Have more questions? Submit a request